Go to top of page

Browser support

Having an up to date browser is an essential part of your online security.

Using an outdated browser version will limit your experience and prevent you from accessing the PPSR.

If you see a warning message when you visit the PPSR you are likely using an outdated browser.

Supported browser versions for accessing the PPSR include:

  • Internet Explorer 11
  • Mozilla Firefox version 35 or above
  • Google Chrome version 45 or above
  • Safari version 8 or above.